Thank you for choosing to drive and earn with Taxify.

In order to ensure optimal performance of your Taxify driver app, please make sure that your device meets these requirements:

  • The app requires heavy GPS and battery usage. Therefore, it is strongly recommended to use higher-end devices on our platform that run on OS 6.0 or newer (for Android) or iOS 8 or newer (for Apple).
  • Your device should have at least 1GB of RAM.
  • Do not use battery saver mode as this may cause GPS errors. 
  • Make sure your phone is connected to a charger during a ride.
  • Use a phone holder to make sure you always get the best possible GPS signal and Internet connection. 
  • Do not forget that your location settings should always be set to high accuracy.
  • Rooted phones are not recommended.

When choosing your device, keep the above requirements in mind to ensure the optimal performance of your driver app. 

Note: If your device shows problematic behavior, your account may get temporarily blocked

Did this answer your question?