We encourage all drivers to use a modern smartphone. Older, non-standard phones and tablets are often not powerful enough to run the Taxify app properly. Your device must have sufficient capacity to keep the driver app operating. When choosing the device, make sure that it supports 4G internet. 

Please make sure to use the most recent driver version of the app, downloaded from either the Google Play Store or App store. We recommend you use the automatic app updating function enabled on your smartphone to ensure you're version of the app is always up to date.

The following are instructions on how to allow auto-updates on Android and iOS

Android:

  • Open Google Play Store
  • Tap Menu and then My Applications and Games
  • Search for the Taxify Driver app and tap More
  • Check the box Auto-update.

iOS:

  • Go to Settings
  • Tap iTunes & App Store
  • Ensure that Automatic Updates are enabled for apps. 

Finally, make sure that you are using the fast 4G Internet. Every month you should expect data usage of approx. 1-2 GB.

Did this answer your question?